Elitech DHC-100 problems

Beginners FAQ on sausage making, meat curing etc may often be found at the head of each relevant section, but here is the place to ask experienced users for advice if you are still stuck or need more information...we're here to help!

Elitech DHC-100 problems

Postby Sam3 » Sat Jan 20, 2018 5:21 pm

Good evening, I hope everyone is keeping well.

As a newbie here and someone who is just in final stages of building / converting fridge into a curing chamber, I have now came across a technical issue with above controllers

Hence I Need some help from you intelligent and experienced ladies and gentlemen.

I have today finally received my second elitech Humidity controller, for to install into curing chamber control panel.

One for humidifier and one to control dehumidifier.

However my problem is the two sensors are both giving completely different readings

Have read in the instructions about calibration, and changed one sensors Data to the same as the other sensor thinking this would make them read the same, alas no avail, so I am guessing that both sensors need calibrated, but haven’t a clue how to.

Do any of you know how to do this and what the “zero offset” and “slope” figures mean / represent
Sam3
Registered Member
 
Posts: 7
Joined: Tue Dec 19, 2017 11:42 am

Re: Elitech DHC-100 problems

Postby wheels » Sat Jan 20, 2018 6:37 pm

Are they both in the same area of the chamber?
User avatar
wheels
Global Moderator
 
Posts: 12483
Joined: Sat Sep 02, 2006 4:29 pm
Location: Leicestershire, UK


Return to Beginners

Who is online

Users browsing this forum: No registered users and 2 guests